# After Installation I get a blank page for Kreport 4.2

**URL:** <https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279>\
**Category:** KReporter\
**Created:** [March 22, 2018, 5:18pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279 "2018-03-22T17:18:47Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 22, 2018, 5:18pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/1 "2018-03-22T17:18:47Z")

</div>

After a good installation of  
KREST API (I have positive veryfication of API)  
I try to create a report and I have a blank screen (png here attached)

 ![03](https://canada1.discourse-cdn.com/flex030/uploads/spicecrm/original/1X/fbdcd269c8ef4d23e4630f4db21b6fdc1af0566b.png)

in LINUX with  
|Apache | 2.4.29|  
|PHP | 5.6.33|  
|MySQL | 5.6.38|

KREST api positive running version 2.5.3  
KPREPORTER 4.2.0 base + core installed (no error during the installation)

SUITECRM 7.9.5

Folder KREPORTER with permission 777

I got the following log Error from server when I try to add a new report  
[pid 15315:tid 139890331457280] (13)Permission denied: [client 213.82.25.115:60009] AH00529: /home/crmidblab/public\_html/SuiteCRM/modules/KReports/.htaccess pcfg\_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/crmidblab/public\_html/SuiteCRM/modules/KReports/’ is executable, referer: [http://www.crm.idblab.com/SuiteCRM/index.php?module=KReports&action=EditView&return\_module=KReports&return\_action=DetailView](http://www.crm.idblab.com/SuiteCRM/index.php?module=KReports&action=EditView&return_module=KReports&return_action=DetailView)

I haven’t found any .htaccess in /KReports module …

Can some help me? 🙂

Mirco

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 6:49am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/2 "2018-03-23T06:49:49Z")

</div>

Second screenshot

 ![16](https://canada1.discourse-cdn.com/flex030/uploads/spicecrm/original/1X/bd43b6efcc2f50741c75ac13628787ffefa14fa1.png)

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 6:51am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/3 "2018-03-23T06:51:40Z")

</div>

Mirco,  
it looks like SuiteCRM has some logic checking htaccess files.  
I only have 7.9.0 and KReporter works there.  
Have you to tried to save a blank .htaccess file under modules/KReports/ ?

Val

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 8:03am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/4 "2018-03-23T08:03:28Z")

</div>

another thing: any error in php error log?  
like  
Call to undefined method Slim\Http\Headers::extract() in C:\xampp\htdocs\suitecrm7102\KRE ST\Slim\Environment.php:161

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 11:22am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/5 "2018-03-23T11:22:19Z")

</div>

Maretval …thanks a lot for your assistance!!  
_1) I create .htaccess empty and the things changes …but not solved …_  
after that It creates a “new report” but only the row …it looks like I don’t have permission for modify or create it …(I am Admin of course)  
Here you have the listed report …created (but I even don’t know how I did it …I just nervously clicked New…Save …:))

 ![10](https://canada1.discourse-cdn.com/flex030/uploads/spicecrm/original/1X/b5ccc88a98f4dca10401d2b75ebb1227c9938908.png)

_2) about the error in php_

**In error\_log nothing similar founded, I have still the same error row**  
[Fri Mar 23 12:04:20.214145 2018] [core:crit] [pid 19172:tid 139890113054464] (13)Permission denied: [client 5.170.172.46:52498] AH00529: /home/crmidblab/public\_html/SuiteCRM/modules/KReports/js/.htaccess pcfg\_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/crmidblab/public\_html/SuiteCRM/modules/KReports/js/’ is executable, referer: [http://crm.idblab.com/SuiteCRM/index.php?module=KReports&offset=1&stamp=1521803016074049900&return\_module=KReports&action=EditView&record=b1cb61e3-35f4-bdac-c970-5ab4dee6156f](http://crm.idblab.com/SuiteCRM/index.php?module=KReports&offset=1&stamp=1521803016074049900&return_module=KReports&action=EditView&record=b1cb61e3-35f4-bdac-c970-5ab4dee6156f)

\*\* In error\_log\_php nothing similar founded, the errors which I have are the following\*\*  
[23-Mar-2018 12:14:12 Europe/Rome] PHP Strict Standards: Declaration of SugarWidgetSubPanelEditRoleButton::displayHeaderCell() should be compatible with SugarWidgetField::displayHeaderCell($layout\_def) in /home/crmidblab/public\_html/SuiteCRM/include/generic/SugarWidgets/SugarWidgetSubPanelEditRoleButton.php on line 0  
[23-Mar-2018 12:14:12 Europe/Rome] PHP Strict Standards: Declaration of SugarWidgetSubPanelEditRoleButton::displayList() should be compatible with SugarWidgetField::displayList($layout\_def) in /home/crmidblab/public\_html/SuiteCRM/include/generic/SugarWidgets/SugarWidgetSubPanelEditRoleButton.php on line 0  
[23-Mar-2018 12:14:41 Europe/Rome] PHP Strict Standards: Declaration of KReport::save() should be compatible with SugarBean::save($check\_notify = false) in /home/crmidblab/public\_html/SuiteCRM/modules/KReports/KReport.php on line 0  
[23-Mar-2018 12:14:41 Europe/Rome] PHP Strict Standards: Declaration of KReport::create\_new\_list\_query() should be compatible with SugarBean::create\_new\_list\_query($order\_by, $where, $filter = Array, $params = Array, $show\_deleted = 0, $join\_type = ‘’, $return\_array = false, $parentbean = NULL, $singleSelect = false, $ifListForExport = false) in /home/crmidblab/public\_html/SuiteCRM/modules/KReports/KReport.php on line 0  
[23-Mar-2018 12:14:41 Europe/Rome] PHP Warning: Invalid argument supplied for foreach() in /home/crmidblab/public\_html/SuiteCRM/modules/KReports/KReport.php on line 427

Do you need some other data or info 🙂 thanks a lot for your effort!!!  
Mirco

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 11:23am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/6 "2018-03-23T11:23:07Z")

</div>

This is the first screen shot (I can insert only one picture per post ☹

but when I click on it for modify …or do something it looks like I can’t do nothing

 ![13](https://canada1.discourse-cdn.com/flex030/uploads/spicecrm/original/1X/820b6f36c45f1f14f2c05bae82831a5421662ab5.png)

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 11:41am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/7 "2018-03-23T11:41:52Z")

</div>

Mirco,

As far as I can see KReporter display is not loading in create view.  
Let’s try this to make sure we don’t overlook fatal errors in php log:  
set in your php.ini:  
error\_reporting=E\_ALL & ~E\_STRICT & ~E\_NOTICE & ~E\_DEPRECATED & ~E\_WARNING  
display\_errors=Off

Then restart server and give another try

Val

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 2:30pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/8 "2018-03-23T14:30:10Z")

</div>

Ok, done. but what now?  
I have tried again and it creates 2 report …as before …empty …that I cannot view/modify

now error\_log\_php has no error displayed  
but error\_log has this

[Fri Mar 23 15:20:05.100560 2018] [core:crit] [pid 48511:tid 139890180196096] (13)Permission denied: [client 5.170.48.32:25849] AH00529: /home/crmidblab/public\_html/SuiteCRM/cache/jsLanguage/KReports/.htaccess pcfg\_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/crmidblab/public\_html/SuiteCRM/cache/jsLanguage/KReports/’ is executable, referer: [crm.idblab.com/SuiteCRM/index.php?module=KReports&offset=2&stamp=1521814799064036600&return\_module=KReports&action=DetailView&record=b1cb61e3-35f4-bdac-c970-5ab4dee6156f](http://crm.idblab.com/SuiteCRM/index.php?module=KReports&offset=2&stamp=1521814799064036600&return_module=KReports&action=DetailView&record=b1cb61e3-35f4-bdac-c970-5ab4dee6156f)  
[Fri Mar 23 15:20:05.173047 2018] [core:crit] [pid 48511:tid 139890314671872] (13)Permission denied: [client 5.170.48.32:25421] AH00529: /home/crmidblab/public\_html/SuiteCRM/modules/KReports/js/.htaccess pcfg\_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/crmidblab/public\_html/SuiteCRM/modules/KReports/js/’ is executable, referer:   
[Fri Mar 23 15:20:05.179717 2018] [core:crit] [pid 48511:tid 139890331457280] (13)Permission denied: [client 5.170.48.32:25297] AH00529: /home/crmidblab/public\_html/SuiteCRM/vendor/.htaccess pcfg\_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/crmidblab/public\_html/SuiteCRM/vendor/’ is executable, referer:   
[Fri Mar 23 15:20:05.181795 2018] [core:crit] [pid 48511:tid 139890348242688] (13)Permission denied: [client 5.170.48.32:25677] AH00529: /home/crmidblab/public\_html/SuiteCRM/modules/KReports/js/.htaccess pcfg\_openfile: unable to check htaccess file, ensure it is readable and that ‘/home/crmidblab/public\_html/SuiteCRM/modules/KReports/js/’ is executable, referer:

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 2:46pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/9 "2018-03-23T14:46:28Z")

</div>

Is the user for which permissions are set for KReports folder the same user as for other folders in modules?

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 2:48pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/10 "2018-03-23T14:48:39Z")

</div>

I don’t know how check it …  
I am actually working as admin

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 2:49pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/11 "2018-03-23T14:49:23Z")

</div>

I did a big mistake …I rebuilt now .htaccess from SuiteCRM panel …and now CRM is not opening ☹ …do u know what can I do for repair this mess???

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 2:55pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/12 "2018-03-23T14:55:30Z")

</div>

try: open .htaccess located in root folder of your suitecrm and delete full content

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 2:56pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/13 "2018-03-23T14:56:57Z")

</div>

Done! this works…promise I will never do it again 😃  
ok …back to our previous topic

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 2:59pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/14 "2018-03-23T14:59:08Z")

</div>

when you are logged in server, go to modules folder  
then use command ls -l to list files and folders including permissions, user nad usergroup  
You shall get something like  
-rw-r–r-- 1 www www 924 2011-07-01 20:23 test.txt

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 3:19pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/15 "2018-03-23T15:19:24Z")

</div>

I am in a managed VPS I have no access to command line, can I see it from Files Manager of Cpanel?

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 23, 2018, 3:23pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/16 "2018-03-23T15:23:45Z")

</div>

try right click on folder in files manager. If you see something like properties, have a look at it

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 23, 2018, 3:31pm UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/17 "2018-03-23T15:31:33Z")

</div>

![13](https://canada1.discourse-cdn.com/flex030/uploads/spicecrm/original/1X/5149d08a140cb9119c56c77ebdac2630aed02ad5.png)

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 28, 2018, 7:40am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/18 "2018-03-28T07:40:51Z")

</div>

I can see on the right 0775. What is httpd/unix directory? User and Group?  
What is set for modules/KReports?

Change Permissions looks good by the way

---

<div class="post-metadata">

**Author:** ![mirco\_cervi](https://yyz2.discourse-cdn.com/flex030/user_avatar/community.spicecrm.io/mirco_cervi/32/149_2.png) [@mirco\_cervi](https://community.spicecrm.io/u/mirco_cervi)\
**Post date:** [March 30, 2018, 8:05am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/19 "2018-03-30T08:05:22Z")

</div>

Ciao Maretval, thanks again for ur help!  
modules/KReports =\> 0777  
I don’t know in cpanel how to check User/Group I have tried to install the ssh client but …with no luck!  
Have you other ideas?

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 30, 2018, 9:08am UTC](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279/20 "2018-03-30T09:08:36Z")

</div>

Mirco,  
sorry, no other idea.  
Val

[Next page](https://community.spicecrm.io/t/after-installation-i-get-a-blank-page-for-kreport-4-2/279.md?page=2)
