# Http failure response for http://spicecrm.domain.com/backend/spiceinstaller/install

**URL:** <https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609>\
**Category:** Installation\
**Created:** [June 30, 2021, 6:30pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609 "2021-06-30T18:30:26Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![wyzooAdmin](https://avatars.discourse-cdn.com/v4/letter/w/439d5e/32.png) [@wyzooAdmin](https://community.spicecrm.io/u/wyzooAdmin)\
**Post date:** [June 30, 2021, 6:30pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/1 "2021-06-30T18:30:26Z")

</div>

I am just about fully SpiceCRM installed, but I have one last error that happens just after I click the ‘begin installation’ button:

“Http failure response for [http://spicecrm.domain.com/backend/spiceinstaller/install:](http://spicecrm.domain.com/backend/spiceinstaller/install:) 500 Internal Server Error”

I looked in all the logs I could find, nothing much telling there.

apache2 -v = Apache/2.4.41 (Ubuntu)  
mysql - v = 8.0.25-0ubuntu0.20.04.1 (Ubuntu)  
php -v = v7.4.3

Tried ‘all-in-one’ but it just hung

Reverted to be/fe git clones in root /var/www/html/frontend and /var/www/html/backend respective directories

Thoughts?

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [June 30, 2021, 7:13pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/2 "2021-06-30T19:13:36Z")

</div>

You tried the all-in-one from [GitHub - spicecrm/spicecrm: SpiceCRM Master](https://github.com/spicecrm/spicecrm)

master branch?

---

<div class="post-metadata">

**Author:** ![wyzooAdmin](https://avatars.discourse-cdn.com/v4/letter/w/439d5e/32.png) [@wyzooAdmin](https://community.spicecrm.io/u/wyzooAdmin)\
**Post date:** [June 30, 2021, 7:29pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/3 "2021-06-30T19:29:29Z")

</div>

Yes … I cloned that to /var/www/html/spicecrm and then went to [http://domain/spicecrm](http://domain/spicecrm) to start the process.

The installation did seem to start, at first with a ‘loading…’ message, then it changed to a ‘connecting…’ message, but that is as far as it went.

I let it run for about 15 minutes, then reverted to the dual clone method (which did not produce results, even with minor adjustments to different parameters)

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [June 30, 2021, 7:44pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/4 "2021-06-30T19:44:49Z")

</div>

ok. So you can’t start the process at all.  
Delete browser cache and try again  
I just performed an installation it worked properly.

---

<div class="post-metadata">

**Author:** ![wyzooAdmin](https://avatars.discourse-cdn.com/v4/letter/w/439d5e/32.png) [@wyzooAdmin](https://community.spicecrm.io/u/wyzooAdmin)\
**Post date:** [June 30, 2021, 11:00pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/5 "2021-06-30T23:00:21Z")

</div>

Thanks for the clear browser hint. Installed on fresh virtual machine, then all went well using a fresh Firefox browser session.

**Next question** : what is the correct value for \*Backend URL when using the all-in-one git clone? I had cloned to a /var/www/html/spicecrm directory, then tried ‘[http://spice.domain.com/spicecrm](http://spice.domain.com/spicecrm)’ in the ‘Define Backend Connection’ dialogue. No matter which combination of DNS or IP used, I was greeted with a ’ http response code 404 returned from server’ error

/var/log/php\_errors.log = empty

Here are the shell commands used:  
cd /var/www/html  
git clone [GitHub - spicecrm/spicecrm: SpiceCRM Master](https://github.com/spicecrm/spicecrm) spicecrm  
mkdir -p config/sites  
chmod +w config/sites  
chown www-data -R spicecrm/

As per video instructions, the '/etc/apache2/sites-enabled/000-default.conf ’ file was modified as follows:

Uncommented = ServerName [spice.domain.com](http://spice.domain.com)

Added =  
\<Directory /var/www\>  
Options Indexes FollowSymLinks Includes  
AllowOverride All  
Require all granted  
Allow from all

…

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [July 1, 2021, 5:23am UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/7 "2021-07-01T05:23:52Z")

</div>

If you call frontend by url being [http://domain/spicecrm](http://domain/spicecrm)  
then backend is [http://domain/spicecrm/api](http://domain/spicecrm/api)

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [July 1, 2021, 5:42am UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/8 "2021-07-01T05:42:19Z")

</div>

Installation Guide for all in one  
[SpiceCRM\_UI\_installation\_guide\_allinone.pdf](https://community.spicecrm.io/uploads/short-url/rmmlLntCFngk4cuxniUkIWC5kO.pdf) (904.8 KB)

---

<div class="post-metadata">

**Author:** ![wyzooAdmin](https://avatars.discourse-cdn.com/v4/letter/w/439d5e/32.png) [@wyzooAdmin](https://community.spicecrm.io/u/wyzooAdmin)\
**Post date:** [July 1, 2021, 12:42pm UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/9 "2021-07-01T12:42:06Z")

</div>

Thanks … waiting for DNS to propagate.

I can see Systems Requirements results if I use the IP address in \*Backend URL field ( ex: [http://IP/myspicecrm/api](http://IP/myspicecrm/api) ), but the System Requirements page is blank if I use the DNS name ( ex: [http://domain/myspicecrm/api](http://domain/myspicecrm/api) ). I am assuming this is a DNS issue and will wait for some period to re-try.

---

<div class="post-metadata">

**Author:** ![chiki](https://avatars.discourse-cdn.com/v4/letter/c/3d9bf3/32.png) [@chiki](https://community.spicecrm.io/u/chiki)\
**Post date:** [March 12, 2022, 6:11am UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/10 "2022-03-12T06:11:17Z")

</div>

I followed manual posted here by maretval in July last year. Did a git clone as described in manual. Was able to go trough all installation screens. No issues find on system requirements page etc. Installation started and after 10 minutes I got following error: “Http failure response for [http://spicecrm.domain.com/api/install…:](http://spicecrm.domain.com/api//install...:) 500 Internal Server Error”

I checked on git repository and on my server and I don’t see any install subfolder in api folder. Not sure if this can be an issue?

---

<div class="post-metadata">

**Author:** ![maretval](https://avatars.discourse-cdn.com/v4/letter/m/b38774/32.png) [@maretval](https://community.spicecrm.io/u/maretval)\
**Post date:** [March 12, 2022, 7:24am UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/11 "2022-03-12T07:24:40Z")

</div>

install Folder under api/ no longer exists, that is ok.  
you cloned master branch of public repository [GitHub - spicecrm/spicecrm: SpiceCRM Master](https://github.com/spicecrm/spicecrm)  
Which php version do you have?  
Which mysql Version? compatibility for mysql 8.0 is not achieved yet.  
Which database collation did you select? Some environments make problems with utfmb4.

---

<div class="post-metadata">

**Author:** ![chiki](https://avatars.discourse-cdn.com/v4/letter/c/3d9bf3/32.png) [@chiki](https://community.spicecrm.io/u/chiki)\
**Post date:** [March 12, 2022, 9:07am UTC](https://community.spicecrm.io/t/http-failure-response-for-http-spicecrm-domain-com-backend-spiceinstaller-install/609/12 "2022-03-12T09:07:54Z")

</div>

Yeah, I moved to another server where mysql is 8.0. After downgrade to 5.7 all works fine.
