Database Error upon installation, all Null values


#1

I tried to install SpiceCRM, and I received a message near the end of the install. All the tables (that I checked) have null values (even though this is my second try and I checked I want demo data).

This is the contents of the sugarcrm.log file:

Mon Jan 15 20:37:54 2018 [1863][-none-][FATAL] Error creating table: sysfts Query Failed: CREATE TABLE sysfts (module varchar(255) NULL ,index_priority int NULL ,ftsfields text NULL ,activated_date date NULL ,activated_fields text NULL ,settings text NULL , PRIMARY KEY (module)) CHARACTER SET utf8 COLLATE utf8_general_ci: MySQL error 1171: All parts of a PRIMARY KEY must be NOT NULL; if you need NULL in a key, use UNIQUE instead

Any ideas on what I should do? It’s my second attempt and while I would like to kick the tires and perform a comparison with my current solution, I’m not able to.

I have ubuntu 16.04 running php7 and mysql database.

Thanks in advance


#2

Content for sysfts table is generated dynamically. It looks like there is a check missing there.
Does the installation go through when you only click demo data and not fts data?


#3

Thanks for your reply.

I’ve tried to install twice, once without demo data, and the second time with.

Both times with the same result. The tables are made, and other than the small message of an error, it appears to have installed correctly. In the user table, all values are null and I can’t login.

I just tried to login now (to the second attempted installation), and I receive the following message:

Url rewrite is not working. Please ensure you have enabled and configured url rewriting on this webserver.

Maybe that’s the issue? if so, any advice on how to solve that? And does that mean another reinstall?

Also, I’m not sure if this matters, albeit I’m currently using a 192.168.x.x and not using a domain.

Thanks again


#4

Which version of php7 and mysql are run exactly? PHP7.0? 7.1? 7.2? MySQL 5.7?

Please check KREST installation guide for url rewrite issue:


#5

I re-run an installation with demo data, it worked.