How do I enable rewrite in MAMP apache?

#1

I installed suiteCRM on MAC using MAMP for apache, mySQL etc. and it is running properly.

In your KREST installation guide, you ask for entering ‘a2enmod rewrite’ in an linux environment.
But where in a MAMP environment must I start the rewrite module?
Unortunately, I’m not an apache specialist… :slight_smile:

I tried to find it in the apache/httpd.conf file, but there, is only one entry
’LoadModule rewrite_module modules/mod_rewrite.so’.

The KREST api was installed and started properly, but the sysinfo-check gives me only an empty screen.

Would be happy to get the solution…

Thank you
Carpe.

#2

adding the module to load if it is there on a MAC should already do it. Also you will need to set AllowOverrid to All in the section of your config.

Since MACs are typically end points and not servers we did/do not focus on that. But it is basic apache configuration.

#3

Thank you for your answer.

Unfortunately it doesn’t run up to now.

I set Allow Override to All in httpd.conf:

DocumentRoot: The directory out of which you will serve your

documents. By default, all requests are taken from this directory, but

symbolic links and aliases may be used to point to other locations.

MAMP DOCUMENT_ROOT !! Don’t remove this line !!

DocumentRoot “/Applications/MAMP/htdocs”

Each directory to which Apache has access can be configured with respect

to which services and features are allowed and/or disabled in that

directory (and its subdirectories).

First, we configure the “default” to be a very restrictive set of

features.

Options Indexes FollowSymLinks AllowOverride All

I restarted the server, installed KREST via the suiteCRM module loader, I did a quick repair in SuiteCRM…

But I still get an empty screen while looking for KREST/sysinfo on SAFARI. On Chrome, I get a http 500 error…

In the apache error-log is no entry, but, in the PHP-error-log. Because I’m not allowed to send it to you, here is a dropbox link on it https://www.dropbox.com/s/6qwki8opg2lrtnz/php-error.pdf?dl=0

Any idea what to do next?

#4

what version of PHP are you running on?

#5

the PHP-Version is 7.1.1

#6

that is I assume the issue. 7.1 is not yet supported. You woudl need to go back to 7.0 … 7.1 is even more strict and sugar in its core does not fully uspport this. There is quite some more cleanup we have to do there.

#7

thank you. I’m not sure that it is possible to downgrade to PHP 7.0…

Do you have PHP 7.1 in your roadmap for KRESt and will it be in 2017?

#8

downgrading php shoudl be no issues. Yes we will certainly also support php 7.1 but there is way more to adopt in the sugar core to do this right. It will liklely happen until mid of the year, latest in Q3.

#9

In the meantime I found that you can configure MAMP for using PHP 7.0 so installation of KREST and KREPORTER worked perfectly.

Thank you very much!

Carpe.