KReporter 4.2 treeview issue


#1

Hi,

We have recently updated to KReporter v4.2 and we’re seeing an issue with a treeview report. When I run the report no data is displayed and there is a SQL error in the sugarcrm.log. When I turn the query analyser on a different query is outputted than in the sugarcrm.log, this query works when I run in manually. This report worked as expected before the upgrade and other treeview reports are working after the upgrade. Any ideas what the issue might be?

Thanks,
Jonny


#2

Jonny,

I need to see the query. Could you send me the error + query thrown in sugarcrm.log?

Valérie


#3

Hi Valérie,

Emailed the details to you there.

Thanks,
Jonny


#4

The issue is how we define queries with grouping clause.
MySQL error 1056: Can’t group on 'k781089439a8c80b6b7363468e5e6’
We used to have a condition for mssql and oracle (use MIN() on grouped field) until KReporter 4.1.
In KReporter 4.2 we removed it since newest mysql works the same way. Maybe too new for now.
For next release we will probably introduce an additional sugar_config variable and restore the condition statement.