SpiceCRM

Can't get KReporter (Slim) to work

I’m not able to get KREST to work.
I’ve checked whether rewrite is working and it is.

For debugging I turned on “display_errors” in index.php.
When I open e.g. /KREST/sysinfo I see the following error:

Fatal error: Call to undefined method Slim\Http\Headers::extract() in /Users/johnezs/Sites/SuiteCRM-7.10/KREST/Slim/Environment.php on line 161

Any idea what might be causing this?

I’m running it on a Mac running Apache.

John,
Which KReporter Version and which KREST version did you install?
Which PHP version?
Val

Apache/2.4.28 (Unix)
PHP/5.5.38

KReporter v4.2.0
KREST Core v2.5.3 (I tried v2.5.2 as well)

PHP 5.6 is minimum recommended.
5.5 should work but it might be the problem. Before you consider an update:

Have you checked access right on all KREST/Slim files?

Does your KREST/Slim folder look like

Val

Yes that’s my folder structure. With 5 files in the “Middleware” folder.

Yes all files belong to u:g for apache user with chmod 777.

I have upgraded my PHP to Version 5.6.33.

Apache/2.4.28 (Unix) PHP/5.6.33

Now I get a slightly more verbose error message :slight_smile:

What are your settings in php.ini for error_reporting?

I seem to have multiple .ini files that get picked up. According to phpinfo it’s currently set to

32767 E_ALL (integer)

(keep in mind I turned on “display_errors” in KREST’s index.php as well for debugging this problem)

Please set to E_ALL & ~E_STRICT
Then turn off “display_errors” in KREST’s index.php
Then try to call krest/sysinfo again

That’s what I started with. I turned on display_errors in KREST’s index.php to get some idea of what’s going on.

This is what I get in Chrome when display_errors is off.

John,

ok. Then you still get the error "undefined method slim\Http\Headers::extract()"
It might an include path problem.
in kREST/index.php
there is on line 33 there is
chdir(dirname(FILE) . ‘/…/’);

This line should throw a warning in php error log if something is wrong. Do you find any warning in error log?
Val