Unable to create report


#1

Hi all.
I’ve setup a new suitecrm 7.10 system and installed afterwards Krest2.5.3, Kreporter Base 4.2 and Kreporter Core 4.2
Then I want to create a new report. Edit view is Loading but I cannot do something. No dropdown or button is working.

In Apache-error log I found following:
Uncaught Error: Call to undefined method Slim\Http\Headers::extract() in /var/www/suitedev/KREST/Slim/Environment.php:161\nStack trace:\n#0 /var/www/suitedev/KREST/Slim/Environment.php(76): Slim\Environment->__construct()\n#1 /var/www/suitedev/KREST/Slim/Slim.php(159): Slim\Environment::getInstance()\n#2 /var/www/suitedev/KREST/Slim/Helper/Set.php(228): Slim\Slim->Slim\{closure}(Object(Slim\Helper\Set))\n#3 /var/www/suitedev/KREST/Slim/Helper/Set.php(88): Slim\Helper\Set->Slim\Helper\{closure}(Object(Slim\Helper\Set))\n#4 /var/www/suitedev/KREST/Slim/Helper/Set.php(185): Slim\Helper\Set->get(‘environment’)\n#5 /var/www/suitedev/KREST/Slim/Slim.php(164): Slim\Helper\Set->offsetGet(‘environment’)\n#6 /var/www/suitedev/KREST/Slim/Helper/Set.php(228): Slim\Slim->Slim\{closure}(Object(Slim\Helper\Set))\n#7 /var/www/suitedev/KREST/Slim/Helper/Set.php(88): Slim\Helper\Set->Slim\Helper\{closure}(Object(Slim\Helper\Set))\n#8 /var/www/suitedev/KREST/Slim/Slim.php(234): Slim\Helper\Set->get(‘request’)\n#9 /var/www/suitedev/KREST/i in /var/www/suitedev/KREST/Slim/Environment.php on line 161, referer: https://crm-dev-01.itdesign.at/suitedev/KREST/sysinfo

I’m working on ubunto 16.04 with php 7.0.32.
filerights and owner on KREST and Kreports are correct.

I also set RewriteBase /suitedev/KREST in the .htaccess file which doesn’t solve the problem.
When I go to …/suitedev/KREST/sysinfo I get same error in Apache error log and 500 error in browser debugger.

Any Idea?


#2

KReporter 4.2 is not compatible with SuiteCRM 7.10.
We are currently working on a capability with KReporter 4.4 and a workaround for installing KREST.


#3

hi.
Which version are supported?
regards robert


#4

Versions supported are the ones before SuiteCRM 7.10, before suitecrm added a vendor/slim folder.
Slim library is also used in KREST and there is a conflict.
What you can do is rename vendor/slim to vendor/slim_
or install a suitecrm 7.9

Coming up soon is KReporter 4.4 with KREST 3.1. and a workaround to avoid problems with slim (and other) libraries.


#5

I’ve tried in a Suitecrm 7.8.20 system and it also doesn’t work.

…/KREST/sysinfo works
Old Reports can be run

But when I try to edit or to create a new report, I can do nothing

There is no error in Apache log or in php Errorlog.
Also in Console.log, I cannot find any error.


#6

in suitecrm.log either?
I think there is a thread with this problem somewhere in the community.


#7

No errors in the logs.


#8

I found the thread related to same behaviour but it was under a suitecrm 7.10 with renaming vendor/slim_ folder as a workaround.
KReporter 4.2 free version will work under 7.10 with the workaround. With KReporter 4.2 pro meaningful funtionalities like Dashlet display do not work.

I can only guess that some php error is triggered in your 7.8 version.
If an error is occuring in the background we should be able to catch it by doing this:
open KREST/index.php and comment the first 2 lines
//error_reporting(1);
//ini_set(‘display_errors’, 0);

Save and “create new report”. See if get errors in php log .


#9

I’ve remarked and tested again. It doesn’t display any error in the logs.

BUT I tried with different Browser and all works fine.
So the Problem is only with Firefox 63.0.3 (64-Bit), I’ve tested with Chrome and Edge. there is no Problem.


#10

Same Problem with Firefox 60.3esr 32 bit