Installation - UI Language Config - REST Call error somewhere... Action aborted


#1

Hey guys

I have been trying to install the new UI for the last couple of days following the installation guide, and I believe I have all the working elements but getting a couple of errors on step 5 and cannot see anything in the sugar errorlogs. When I try the Front End URL it starts loading after your login attempt but hangs on loading the Language component.

UI Language Config
/index.php?module=Administration&action=UILanguage
Error - “REST Call error somewhere… Action aborted”

UI Config
/index.php?module=Administration&action=UIDefault
Error - “REST Call error somewhere… Action aborted”

Love to get your direction on what could be causing the issue

I also noticed that the packages https://packages.spicecrm.io/ gives a 404 error, wasnt sure if this was related.

Cheers


#2

Looks like our configuration server crashed. We check that will keep you posted.


#3

Do you get a 404 when calling https://packages.spicecrm.io/releaselanguage/en_us/*/*


#4

This url works, screenshot attached
https://packages.spicecrm.io/releaselanguage/en_us//


#5

ok, thanks. That’s good. I am checking the language loader logic in spicecrm download package.


#6

I downloaded spicecrm_be_release_core master, I installed (after adding a hotfix which is now committed to master branch) it.
I went to administration > UI Language config
I selected English
grafik
I got no error
grafik

Did you download master or release branch?


#7

May have been the master, was there any database changes between master and release?


#8

Master would be wise.
Could you re-download to make sure you are up-to-date?


#9

Fresh download and install and we are working!

Cheers mate


#10

Hey mate,
Still struggling to get a stable version working with data populating in the Front end. Been a working progress since release

My devs are getting messages that there are missing files. We have reinstalled it a few different types on a few different environments.

Error screenshot attached

also
"unable to load DB manager for: " and this error in log file repeats on each page almost

Question:
I am hoping to isolate and remove any configuration issues and get a working version happening on our testing server.
Do you have a full working backup of the demo environment you could share which has already been configured? From which I can change the site URL / Elasticsearch engine and see if it removes any config issues to see if I have any other issues with the server config.


#11

Try this:
Truncate all your sysui tables in database
TRUNCATE TABLE sysuimodulerepository;
TRUNCATE TABLE sysuiobjectrepository;
TRUNCATE TABLE sysuiroutes;
TRUNCATE TABLE sysuicomponentsets;
TRUNCATE TABLE sysuicomponentsetscomponents;
TRUNCATE TABLE sysuifieldsets;
TRUNCATE TABLE sysuifieldsetsitems;
TRUNCATE TABLE sysuiactionsets;
TRUNCATE TABLE sysuiactionsetitems;
TRUNCATE TABLE sysuiadmincomponents;
TRUNCATE TABLE sysuicomponentdefaultconf;
TRUNCATE TABLE sysuicomponentmoduleconf;
TRUNCATE TABLE sysuicopyrules;
TRUNCATE TABLE sysuifieldtypemapping;
TRUNCATE TABLE sysuilibs;
TRUNCATE TABLE sysuirolemodules;
TRUNCATE TABLE sysuiroles;
TRUNCATE TABLE sysuidashboarddashlets;

Go to bakend > Administration > SpiceUI Config > UI Configload config but only core

Delete your browser cache.
Close Browser
Reload UI


#12

Hey mate,

Appreciate you help on this mate

Did the above and also a rebuild after I got the below, still no love

Unable to login now after, “… loading Components …” :frowning:
Capture

DT


#13

Looks like the core table didnt clean up, let me try again

  • aclmanager
  • aclterritories
  • core
  • core
  • deployment
  • knowledgebase
  • portal
  • productmanagement
  • projectmanagement
  • questionnaires
  • reporting
  • salesdocuments
  • service
  • telecockpit
  • workflow

#14

The TRUNCATE cleared everything but core and projectmanagement packages.
Then when I load the core package it doubles up and I get the “loading components” on login


#15

OK. I’ll try an install on local environment to see what happens.
You did delete browser cache and closed browser before reloading UI, didn’t you?


#16

full system purge with ccleaner


#17

Could you mention php version,
Database type and version
Browser name and version?


#18

Chrome Version 70.0.3538.102 (Official Build) (64-bit)
Ubuntu 16.04 (x86_64)
PHP version: 7.0.32-0ubuntu0.16.04.1
MySQL: 5.7.24-0ubuntu0.16.04.1 - (Ubuntu)


#19

Hello, I also get the same error on successful install relating to aclterritories etc.

Today on a fresh install and existing (semi-working environment) I cannot load any packages when selecting UI Language config or UI Config. Both give a blank screen.

The sub URL for language above works in the browser. Fresh master package install.

Regards, Jake.


#20

You should find a mySQL error in sugarcrm.log. Please grab it and post it.