SpiceCRM

Http failure response for http://spicecrm.domain.com/backend/spiceinstaller/install

I am just about fully SpiceCRM installed, but I have one last error that happens just after I click the ‘begin installation’ button:

“Http failure response for http://spicecrm.domain.com/backend/spiceinstaller/install: 500 Internal Server Error”

I looked in all the logs I could find, nothing much telling there.

apache2 -v = Apache/2.4.41 (Ubuntu)
mysql - v = 8.0.25-0ubuntu0.20.04.1 (Ubuntu)
php -v = v7.4.3

Tried ‘all-in-one’ but it just hung

Reverted to be/fe git clones in root /var/www/html/frontend and /var/www/html/backend respective directories

Thoughts?

You tried the all-in-one from GitHub - spicecrm/spicecrm: SpiceCRM Master

master branch?

Yes … I cloned that to /var/www/html/spicecrm and then went to http://domain/spicecrm to start the process.

The installation did seem to start, at first with a ‘loading…’ message, then it changed to a ‘connecting…’ message, but that is as far as it went.

I let it run for about 15 minutes, then reverted to the dual clone method (which did not produce results, even with minor adjustments to different parameters)

ok. So you can’t start the process at all.
Delete browser cache and try again
I just performed an installation it worked properly.

Thanks for the clear browser hint. Installed on fresh virtual machine, then all went well using a fresh Firefox browser session.

Next question: what is the correct value for *Backend URL when using the all-in-one git clone? I had cloned to a /var/www/html/spicecrm directory, then tried ‘http://spice.domain.com/spicecrm’ in the ‘Define Backend Connection’ dialogue. No matter which combination of DNS or IP used, I was greeted with a ’ http response code 404 returned from server’ error

/var/log/php_errors.log = empty

Here are the shell commands used:
cd /var/www/html
git clone GitHub - spicecrm/spicecrm: SpiceCRM Master spicecrm
mkdir -p config/sites
chmod +w config/sites
chown www-data -R spicecrm/

As per video instructions, the '/etc/apache2/sites-enabled/000-default.conf ’ file was modified as follows:

Uncommented = ServerName spice.domain.com

Added =
<Directory /var/www>
Options Indexes FollowSymLinks Includes
AllowOverride All
Require all granted
Allow from all

If you call frontend by url being http://domain/spicecrm
then backend is http://domain/spicecrm/api

Installation Guide for all in one
SpiceCRM_UI_installation_guide_allinone.pdf (904.8 KB)

Thanks … waiting for DNS to propagate.

I can see Systems Requirements results if I use the IP address in *Backend URL field ( ex: http://IP/myspicecrm/api ), but the System Requirements page is blank if I use the DNS name ( ex: http://domain/myspicecrm/api ). I am assuming this is a DNS issue and will wait for some period to re-try.