SpiceCRM

Installation Issue - Hangs at "System Requirements"

We are installing SpiceCRM on Ubuntu Server 20.04 exactly per the install guide. The front end is installed in /var/www/html/myspicecrm and the back end is installed in a folder within there called “backend” exactly as the install guide states. All http links are spaced because I can only make a post with 2 links.

We navigate to http : / / IP/myspicecrm/ to begin the installation. We fill out the first page, including setting the backend to “http : / / localhost/myspicecrm/backend”. At this point the installer advances to “System Requirements” and hangs indefinitely. The console shows the following error:

zone.min.js:133 GET http : / / localhost/myspicecrm/backend/KREST/spiceinstaller/check net::ERR_CONNECTION_REFUSED
core.umd.min.js?v=9.1.2:236 ERROR t {headers: e, status: 0, statusText: "Unknown Error", url: "http : / / localhost/myspicecrm/backend/KREST/spiceinstaller/check", ok: false, …}

This led me to believe the frontend installer is looking for KREST on the back end, but that’s not possible to be installed as 1) the link on the downloads page for KREST is broken ( https : / / www.spicecrm.io/downloads/ ) unless you construct the URL manually ( https : / / www.spicecrm.io/download/KREST-Core-2.5.3/ ) 2) It requires SugarCRM to already be up and functioning to install modules, which it isn’t at this point.

I’m using the current download of the github repo as indicated in the install guide, acquired 12/21/2020. For total troubleshooting, below is my ENTIRE installation process thus far:

wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
sh -c 'echo "deb https://artifacts.elastic.co/packages/7.x/apt stable main" > /etc/apt/sources.list.d/elastic-7.x.list'
apt update
apt -y install apache2 php php-simplexml php-soap php-mbstring php-zip php-imap php-curl php-gd apt-transport-https ca-certificates wget elasticsearch git unzip
touch /var/log/php_errors.log
chown www-data:www-data /var/log/php_errors.log
a2enmod rewrite
sed -i 's/display_errors = On/display_errors = Off/g' /etc/php/7.4/apache2/php.ini
sed -i 's|;date.timezone =|date.timezone = America/Los_Angeles|g' /etc/php/7.4/apache2/php.ini
sed -i 's/max_execution_time = 30/max_execution_time = 300/g' /etc/php/7.4/apache2/php.ini
sed -i 's/memory_limit = 128M/memory_limit = 256M/g' /etc/php/7.4/apache2/php.ini
sed -i 's/upload_max_filesize = 2M/upload_max_filesize = 50M/g' /etc/php/7.4/apache2/php.ini
sed -i 's|;error_log = php_errors.log|;error_log = /var/log/php_errors.log|g' /etc/php/7.4/apache2/php.ini
sed -i 's/display_errors = On/display_errors = Off/g' /etc/php/7.4/cli/php.ini
sed -i 's|;date.timezone =|date.timezone = America/Los_Angeles|g' /etc/php/7.4/cli/php.ini
sed -i 's/max_execution_time = 30/max_execution_time = 300/g' /etc/php/7.4/cli/php.ini
sed -i 's/memory_limit = 128M/memory_limit = 256M/g' /etc/php/7.4/cli/php.ini
sed -i 's/upload_max_filesize = 2M/upload_max_filesize = 50M/g' /etc/php/7.4/cli/php.ini
sed -i 's|;error_log = php_errors.log|;error_log = /var/log/php_errors.log|g' /etc/php/7.4/cli/php.ini
sed -i '172s/Off/On/' /etc/apache2/apache2.conf
systemctl restart apache2
systemctl enable --now elasticsearch.service
cd /var/www/html
wget https://github.com/spicecrm/spicecrm_fe_release_core/archive/master.zip
unzip master.zip
mv spicecrm_fe_release_core-master/ myspicecrm
rm master.zip
cd myspicecrm
wget https://github.com/spicecrm/spicecrm_be_release_core/archive/master.zip
unzip master.zip
mv spicecrm_be_release_core-master/ backend
rm master.zip
mkdir -p config/sites
chmod +w config/sites
cd ..
chown -R www-data:www-data myspicecrm

Hi,

have you checked apache error log for more details?

br,

Markus

The apache error log shows absolutely nothing. The php error log is empty. I can see the requests in the access log. The only real errors I get at all are client-side javascript console logs as indicated above.