Php version compatible with spicecrm


#1

Which PHP versions are compatible wth spicecrm ?Is php5 compatible version?


#2

the supported PHP Versions are 5.6 and 7.0.


#3

hello

my php version is 5.5.38

I can see following error during installation of spicecrm.

[Mon Jan 02 22:34:17.923976 2017] [:error] [pid 2679] [client 24.8.79.114:62389] PHP Notice: Undefined index: log in /home/freecrminstall/public_html/crm/include/utils/sugar_file_utils.php on line 84, referer: http://www.freecrminstall.com/crm/install.php
[Mon Jan 02 22:34:17.923997 2017] [:error] [pid 2679] [client 24.8.79.114:62389] PHP Fatal error: Call to a member function error() on a non-object in /home/freecrminstall/public_html/crm/include/utils/sugar_file_utils.php on line 84, referer: http://www.freecrminstall.com/crm/install.php
[Thu Jan 05 19:33:55.304346 2017] [:error] [pid 30906] [client 112.133.232.12:42395] PHP Notice: Undefined index: log in /home/freecrminstall/public_html/crm/include/utils/sugar_file_utils.php on line 84, referer: http://www.freecrminstall.com/crm/install.php
[Thu Jan 05 19:33:55.304374 2017] [:error] [pid 30906] [client 112.133.232.12:42395] PHP Fatal error: Call to a member function error() on a non-object in /home/freecrminstall/public_html/crm/include/utils/sugar_file_utils.php on line 84, referer: http://www.freecrminstall.com/crm/install.php

please help me.


#4

(1) please update your php version
(2) this seems to be a file authorization issues. please set the access rights properly on your server


#5

PHP7 is meant to be compatible? I just tried pointing my installation that works on PHP5 to use PHP7 and the module lists (Accounts, Leads etc.) do not load correctly.


#6

php 7.0 yes … 7.1 is not tested.


#7

I am running php 5.6.30 (as part of xampp on my windows box) - yet I am getting the same errors. Sugar and Suite are running fine


#8

judging from your opther post I assume you did solve it.


#9

PHP 7.2 is due out soon and 7.1.10 was just released.

What is the schedule for PHP 7.1 support?


#10

php7.1 support is scheduled for December 2017 release


#11

This is really great news!