System requirements for installation of spice crm


#1

What are the systems requirements to install spice? The actual xampp comes with MariaDB. Is this okay or is MySQL recommended?

Thanks for help

Karsten


#2

Karsten, we haven’t tested on MariaDB yet. According to https://mariadb.com/kb/en/mariadb/mariadb-vs-mysql-compatibility/ it should work.
Be the first to tell us about your experience with Maria DB!
Valérie


#3

Correction: I use myself xampp and it works. So go for it! But please use the distribution with php 7.0.x
SpiceCRM is not compatible with 7.1.x yet.


#4

Thanks for the tip to use the ‘old’ php 7.0.x


#5

I also confirm. Production environment:

CentOS 7
Apache 2.4.6 OpenSSL / 1.0.1e-fips mod_fcgid / 2.3.9 + SSL (LetsEncrypt)
PHP / 7.0.19
Database client version: libmysql - mysqlnd 5.0.12-dev (10.1.23-MariaDB)

It works.